Why did my reminders stop working?

Why did my reminders stop working?

Postby abishkking » Tue Sep 25, 2018 12:24 pm

The main reason is due to cleaning apps like Clean Master, 360 Security, CM security, Fast Booster and other similar apps. While cleaning your device, these apps terminate Period Calendar’s reminders and put your health at risk. Here’s the only definite way to prevent these apps from interfering with Period Calendar:
1. Go to your device settings.
2. Tap on ‘Accessibility’.
3. Under ‘Services’ turn off the cleaning app.
4. Please restart your device (switch it off and back on).
5. Enter your Period Calendar app.


The above steps and the device-specific steps below should get your reminders up and running again. If you did not get your next reminder please contact us at abishkking@gmail.com and we will assist you.


If you have a Samsung device with Android 6 and Smart Manager, do the following:
1. Go to your Smart Manager app and tap on ‘Battery’.
2. Under ‘App Power Saving’, tap ‘Details’.
3. Tap on ‘Period Calendar’ and tap ‘Disable’.


If you have a Samsung device with Android 7, do the following:
1. Go to your device settings and tap ‘Device Maintenance’, then tap on ‘Battery’.
2. Scroll down and tap ‘Unmonitored apps’, then add Period Calendar to this list.
3. Go to your phone’s Settings, tap “Applications”, tap “Application Manager”, then tap “ Period Calendar”.
4. Tap “Notifications”, enable “Allow Notifications”, then disable “Hide on lock screen”.
5. In Period Calendar, tap ‘More’, tap ‘Settings’, ‘General Settings’, then tap ‘Refresh reminder times’ (under Time Zone Settings).


If you have a Samsung device with Android 8.0, do the following:
1. Open your phone’s Settings app, tap “Apps”.
2. Tap the three-dot icon in the top right corner, then tap “Special access”.
3. Tap “Optimize battery usage”, then tap “Apps not optimized”.
4. Select “All apps”, find Period Calendar and disable it here.
5. Go to your device settings and tap ‘Device Maintenance’, then tap on ‘Battery’.
6. Scroll down and tap ‘Unmonitored apps’, then add Period Calendar to this list.
7. Tap ‘Always Sleeping apps’ and make sure Period Calendar is not listed there.

If you have a Samsung device with Android 9.0, do the following:
1. Open your phone’s Settings app, tap “Apps”.
2. Tap the three-dot icon in the top right corner, then tap “Special access”.
3. Tap “Optimize battery usage”, then tap “Apps not optimized”.
4. Select “All apps”, find Period Calendar and disable it here.
5. Go to your device settings and tap ‘Device care’, then tap on ‘Battery’.
6.Tap the three-dot icon ,then tap “Sleeping apps”.
7. make sure Period Calendar is not listed there.

If you have a Zenfone device, do the following:
1. Go to your ‘Asus Mobile Manager’.
2. Turn on ‘Allow’ for Period Calendar.
3. Go to your app launch manager and allow Period Calendar.
4. Go to battery saving settings and exclude Period Calendar.
5. Allow Period Calendar to autostart in your device’s Autostart Manager.


If you have a Huawei device, do the following:
1. Go to ‘Privacy and Security’ in your device settings.
2. Add Period Calendar to your ‘Protected Apps’.
3. Add Period Calendar in your Startup apps.
4. Go to screen energy saver settings and allow Period Calendar to interrupt the screen energy saver.
5. Go to battery settings, tap ‘Lock screen cleanup’ and exclude Period Calendar.
6. Go to your ‘Settings’, tap ‘Apps’, then ‘Advanced’. Tap ‘Ignore Battery Optimizations’, find Period Calendar and ignore it (not “Allow”).


If you have a Huawei device with Android 8.0 or higher , do the following:
1. Go to your phone Settings and tap ‘Apps & Notifications’, ‘Apps’, ‘Period Calendar’, ‘Battery’. Turn off ‘power intensive prompt’, then select ‘Launch’, turn off ‘Manage automatically’ and change it to ‘manually’.Then turn on ‘Auto-launch’, ‘Secondary launch’ and ‘Run in background’.
2. Go back to ‘Apps’, then tap the ‘Settings’ option at the bottom of the app list. Tap ‘Special access’, then ‘Ignore battery optimization’. Tap the arrow on the top right and choose ‘All apps’. Find Period Calendar in the list of apps and choose ‘Allow’.
3. Go back to ‘Apps’, tap ‘Period Calendar’, then tap ‘Notifications’. Turn on ‘Allow notifications’, ‘Display in status bar’, ‘Banners’, ‘Lock screen notifications’ and ‘Priority display’.


If you have a Xiaomi device, do the following:
1. Go to your device settings and tap ‘Additional Settings’.
2. Tap ‘Battery & Performance’, ‘Manage Apps Battery Usage’, ‘Choose Apps’.
3. Tap on ‘Period Calendar’ and choose ‘No Restrictions’.
4. Go to Settings, Permissions, Autostart (tap here). Turn on Autostart for Period Calendar.
5. Go to your Power settings policy and allow Period Calendar to wake up your device.
6. Open the apps, then press the “Recent Apps”/”App Overview” button (the square button or the button with three horizontal lines).
7. In “Recent Apps”/”App Overview”, find Period Calendar, and pull down on it to “lock it”, so it never gets cleared.


If you have a OnePlus device, do the following:
1. Go to your device settings and tap ‘Battery’.
2. Tap ‘Battery Optimization’ from the top right menu icon.
3. Select all apps and disable ‘Period Calendar’.
4. Go back to ‘Battery Optimization’, then go to ‘Advanced Optimization’ and disable it.
5. Go to your device settings and tap ‘Sound and Notification’.
6. Tap ‘App Notifications’ and tap on ‘Period Calendar’.
7. Change Period Calendar to ‘Priority’.


If you have a Leeco Le device:
1. Go to your Phone Manager and tap ‘Power Management’.
2. Tap ‘Protection Applications’ and add Period Calendar to the protected applications.
3. Go to ‘Settings’, ‘Permissions’, ‘App Permissions’, ‘App List’, then ‘Period Calendar’.
4. On the options near the bottom, find ‘Alert Window’ under ‘Others’ – set it to ‘Allowed’.


If you have a ZTE Nubia device:
1. Go to ‘Settings’, ‘Apps’, ‘Autostart Management’.
2. Enable ‘Period Calendar’.
3. From your device’s Home screen, tap the Apps icon, ‘Settings’, ‘Notifications’ (Device section).
4. Tap the Gear icon in the upper-right, tap ‘On the lock screen’ then select ‘Show all notification content’.


If you have an Oppo device:
1. Go to Settings and tap ‘Notification and status bar’.
2. Enable ‘Turn on screen for lockscreen notifications’.
3. Go back to ‘Notification panel & status bar’ and tap ‘Notification Center’.
4. Find ‘Period Calendar’, then activate ‘Allow Notifications’ and ‘Priority Display’.
5. Go to your phone’s ‘Settings’, ‘Advanced Settings’, ‘Battery Manager’, ‘Protected Apps’.
6. Find ‘Period Calendar’, and ‘Protect’/’Whitelist’ it.
7. In your phone’s ‘Settings’, tap ‘Apps’, tap ‘Advanced’, tap ‘Ignore Battery Optimizations’.
8. Find ‘Period Calendar’ and choose to ‘Ignore’ it.
You can also lock the apps to keep them running in the background:
1. Go to the apps overview (where you can see all the running apps).
2. Swipe down to lock or unlock Period Calendar – when done correctly, you should see a lock icon on the upper left corner of the app.


If you have a Lenovo device:
1. Go into you phone’s Settings and tap “Apps”.
2. Find the app named “Background app management”.
3. Click on it and then select “Disable”.


If you have a Meizu device:
1. Open “Security” and tap “Accelerator”.
2. Tap the cog icon in the top-right corner and open “Memory acceleration whitelist”.
3. Click on “Add to Whitelist” and select Period Calendar.
4. Go back to “Security” and tap “Permissions”, then “Auto-launched apps” and enable “Period Calendar”.
5. Go back to “Permissions”, tap “App management”, tap on Period Calendar, then enable “Notification” and “Auto-launch”.
6. Go back to the main menu for the “Security” app and select “Power”.
7. Open “Standby management” – when in “Standby Management”, the screen title will read “App management”.
8. Allow Period Calendar here.
If the above steps don’t work:
1. Open the “Security” app, tap “Permission”, tap “Run in background”.
2. Tap “Period Calendar” and choose “Keep running in background”.
Because Meizu uses the FlymeOS – which is significantly different from most Android operating systems – and not standard Android, you may still experience notification issues.


If you have a Blackberry KEYone device:
1. Go to your phone settings, tap ‘Notifications’, tap the settings icon, tap ‘On the lock screen’, ‘Show all notification content’. Tap on ‘Period Calendar’ in the list of apps under ‘Notifications’, turn all the options off.
2. On the home screen, swipe down from the top of the screen.
3. Tap “Settings” icon, then “Notifications”.
4. Tap a profile.
5. Tap Customize App Notifications.
6. Tap an app.
7. Change the Sound, Ringtone, Override Profile Volume, Vibrate, LED, LED Color, or Hub Notification settings.
8. To make the updated settings the default notification settings for the app in all of the notification profiles, tap The Set As Default icon.


If you have a Vivo device:
1. Set Period Calendar in the white list for speedup.
2. Go to “Settings”, “Status bar and notification”, find “Period Calendar”, turn on the “Allow notification”, “Show on lock screen”, “Badge desktop app icon” and the “Top preview” switches.
3. Please go to “Imanager”, “Power manager”, “Excessive background battery usage” and allow Period Calendar to continue running when the background power consumption is high.
4. Please go to Settings, tap “More settings”, tap “Applications”, tap “Autostart”, then turn on the switch for “Period Calendar”.
abishkking
Site Admin
 
Posts: 0
Joined: Mon Jun 18, 2012 3:15 am

Return to Announcement

Who is online

Users browsing this forum: No registered users and 3 guests